JavaScript is required to use Bungie.net

Service Alert
All Destiny releases will be temporarily offline tomorrow for scheduled maintenance. Please stay tuned to @BungieHelp for updates.

Destiny 2

Discuss all things Destiny 2.
5/29/2022 8:56:51 PM
0

2 quests have disappeared/can’t progress

Recently started Destiny 2 within the last two weeks. Working through the campaign, I’ve encountered 2 missions that have disabled me from continuing the campaign. Let’s start with the mission, Riding the Storm. I’ve hit the point where I had to go speak to Ikora in the Tower. Went to do that nothing happened. Tried a few times and just moved on for a bit. Eventually it literally just disappeared and I can’t get it to show anymore. Before anyone says it, yes I’ve tried the Quest Archive. I even tried buying a next gen console…. Jk I was gonna do that any way, but there’s a support issue about that as well I’ll touch on in a bit. Now on the next mission, Learning the Light. I meditated and communed with the Traveler, then the same exact situation as before happened when I had to go speak to Shaw. Nada. Another issue, I tried to do the first mission of Witch Queen on my Xbox One X, everytime we’d “defeat” Savathun, she’d start talking and my Xbox would just turn off to “overheating” with no vent blockage. Couple days later I went to go try the mission on my own, didn’t have to do any fighting and only had to experience the end of the mission. Well I didn’t get the worm from it either for the Glaive. I actually bought a Series X yesterday, so might try it again but I doubt it’s gonna even work. I’m hoping some one can give a good suggestion, or that Bungie takes note of these issues.

Posting in language:

 

Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

You are not allowed to view this content.
;
preload icon
preload icon
preload icon