JavaScript is required to use Bungie.net

Help

Help us help you.
Edited by Racin_Jason_60: 11/30/2020 2:12:37 PM
2

BUG REPORT - Cryptolith Lure Quest Disappears from Quest Page on log out and Seasonal Triumphs stopped working

Hi, My Lure keeps disappearing from my inventory. I either dismantled it or I tried to reset it after selecting the wrong hunt and now it's permanently bugged. My Seasonal triumph for upgrading the Lure stopped working as well. I have provided a link to five screenshots of the issue. In the 1st - I pick up the Lure, in the 2nd you can see it is gone as confirmation, in the 3rd I check my quest log (notice there is no dismantle option like there was the very first time), in the 4th there it shows my Lure fully upgraded, in the 5th it shows my Triumph say 6 out of 7 even though I have all 10 upgrades. Also please let me know if you can't see the screenshots as I just set up a photo-sharing account to show the bugs but I am not sure if I setup it correctly.

Posting in language:

 

Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

View Entire Topic
  • For me it looks like there are only 6 Upgrades out of 7 avialable at this time. So for me, its the same, 6 from 7 Upgrade. If i check DIM, i see there will be one more Mod in the last square, the One that gives better Stats for Gear not lik ethe One in the middle.

    Posting in language:

     

    Play nice. Take a minute to review our Code of Conduct before submitting your post. Cancel Edit Create Fireteam Post

    1 Reply
    You are not allowed to view this content.
    ;
    preload icon
    preload icon
    preload icon